他のバージョンの文書11 | 10 | 9.6 | 9.5 | 9.4 | 9.3 | 9.2 | 9.1 | 9.0 | 8.4 | 8.3 | 8.2 | 8.1 | 8.0 | 7.4 | 7.3 | 7.2

E.6. リリース8.1.4

リリース日: 2006-05-23

このリリースは8.1.3の各種不具合を修正したもので、非常に深刻なセキュリティ問題を解消するパッチを含みます。

E.6.1. バージョン8.1.4への移行

8.1.Xからの移行ではダンプ/リストアは不要です。 しかし、8.1.2より前のバージョンからアップグレードする場合は、8.1.2のリリースノートを参照してください。

CVE-2006-2313およびCVE-2006-2314に示されたSQLインジェクション攻撃を完全に防ぐためには、アプリケーション側のコードの変更が必要となる場合があります。 SQLコマンド内に信頼できない文字列を埋め込むアプリケーションでは、できる限り早く、その文字列が推奨するエスケープ技法を使用していることを確実に検証しなければなりません。 ほとんどの場合、アプリケーションは文字列のエスケープ処理に、その場しのぎのコードではなく、ライブラリやドライバが提供する(libpqPQescapeStringConn()のような)関数を使用しなければなりません。

E.6.2. 変更点